二分图 板题 HDU2444 判断是否为二分图&求二分图最大匹配

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/DADDY_HONG/article/details/84142846

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9512    Accepted Submission(s): 4176

 

Problem Description

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

 

Input

For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

 

Sample Input

4 4

1 2

1 3

1 4

2 3

6 5

1 2

1 3

1 4

2 5

3 6

 

Sample Output

No 3

染色法判断是否为二分图:

无向图G为二分图的充分必要条件是:G至少有两个顶点,且当存在回路时,其所有回路的长度均为偶数。回路就是环路,也就是判断是否存在奇数环。

判断二分图方法:用染色法,把图中的点染成黑色和白色。

首先取一个点染成白色,然后将其相邻的点染成黑色,如果发现有相邻且同色的点,那么就退出,可知这个图并非二分图。

求最大匹配,dfs匈牙利算法回退实现。

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int maxn=205;

int n,m;
bool g[maxn][maxn];
bool vst[maxn];
int match[maxn];
int ans;

//求最大匹配
bool dfs(int x)
{
    vst[x]=1;
    for(int i=1;i<=n;++i){
        if(vst[i]||!g[x][i]) continue;
        vst[i]=1;
        if(!match[i]||dfs(match[i])){
            match[i]=x;
            return true;
        }
    }
    return false;
}

//染色法判断是否为二分图
/*无向图G为二分图的充分必要条件是:G至少有两个顶点,且当存在回路时,其所有回路的长度均为偶数。回路就是环路,也就是判断是否存在奇数环。
判断二分图方法:用染色法,把图中的点染成黑色和白色。
首先取一个点染成白色,然后将其相邻的点染成黑色,如果发现有相邻且同色的点,那么就退出,可知这个图并非二分图。
*/
bool judge()
{
    int color[maxn];
    queue <int> q;
    memset(color,-1,sizeof(color));
    q.push(1);color[1]=0;
    while(!q.empty()){
        int p=q.front();q.pop();
        for(int i=1;i<=n;++i){
            if(p==i) continue;
            if(g[p][i]){
                if(color[i]==-1){
                    color[i]=color[p]^1;
                    q.push(i);//妈耶漏了这句
                }
                else if(color[i]^color[p]==0){
                    return false;
                }
            }
        }
    }
    return true;
}

int main()
{
    int u,v;

    while(~scanf("%d%d",&n,&m)){
        ans=0;
        memset(g,0,sizeof(g));
        memset(match,0,sizeof(match));
        for(int i=0;i<m;++i){
            scanf("%d%d",&u,&v);
            g[u][v]=g[v][u]=1;
        }
        if(!judge()){
            printf("No\n");
            continue;
        }
        for(int i=1;i<=n;++i){
            memset(vst,0,sizeof(vst));
            if(dfs(i)) ++ans;
        }
        printf("%d\n",(ans+1)/2);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/DADDY_HONG/article/details/84142846
今日推荐