HDU--1013--输入小心

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0
Sample Output
6
3

题意:计算数字的每一位之和,知道计算为个位数为止;

注意:输入的数字不明确,因此考虑用字符串输入;

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
    char s[1000];
    while(scanf("%s",s)){
        if(s[0]=='0') break;
        int sum=0;
        for(int i=0;s[i]!='\0';i++){
           sum+=s[i]-'0';
           if(sum>9)	sum=sum%10+sum/10;
        }
        printf("%d\n",sum);
    }
}
发布了170 篇原创文章 · 获赞 73 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104587781