HDU 1013(Digital Roots)

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/86610223
                                              Digital Roots
           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                         Total Submission(s): 96847    Accepted Submission(s): 30084

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0

Sample Output
6
3

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    char a[1000];
    long long int b=0,t=0,i,j;
    while(cin>>a)
    {
        if(strcmp(a,"0")==0)   
            break;
        j=strlen(a);
        for(i=0;i<j;i++)
            b=b+a[i]-48;
        while(b>9)
        {
            while(b>0)
            {
                t=t+b%10;
                b=b/10;
            }
            b=t;
            t=0;
        }
        cout<<b<<endl;
        b=0;
        t=0; 
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/86610223