Digital Roots HDU - 1013

版权声明:本文为博主胡乱瞎写,如有需要,随便转载,顺带给个momo哒。 https://blog.csdn.net/rangran/article/details/81909660

Digital Roots HDU - 1013 

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39. 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero. 

Output

For each integer in the input, output its digital root on a separate line of the output. 

Sample Input

24
39
0

Sample Output

6
3

听取WA声一片,用int就WA。。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char s[1010];
int main()
{

    while(~scanf("%s",s)&&s[0]!='0')
    {
        int len,sum=0,n,i;
        len=strlen(s);
        for(i=0;i<len;i++)
            sum+=s[i]-'0';
        while(sum>=10)
        {
            n=sum;
            sum=0;
            while(n)
            {
                sum+=n%10;
                n/=10;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81909660