HDU 1013 Digital Roots(数学规律)

Digital Roots
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 91066 Accepted Submission(s): 28337

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0

Sample Output
6
3
这道题目容易错的地方就是输入的n这个数据的大小,一开始就直接当做最大long long型的数据来处理,就数据发现规律,n%9,如果结果不为0,那么就是最终的结果root,否则,如果为0,则root为9,最后结果是WA, 后总结发现数据长度可能上千,改用字符串存储n,每位相加后结果不会超过long long,所以上述规律仍然适用,只需要处理掉第一步数据太长的问题就AC了。(后来测试数据的长度不超过1000)

#include<bits/stdc++.h>
using namespace std;
int main()
{
    char n[2000];
    while(scanf("%s",n)!=EOF)
    {
        if(n[0]=='0')
            break;
        int res=0,len=0,sum=0;
        len=strlen(n);
        for(int i=0;i<len;i++)
            sum+=n[i]-'0';
        res=sum%9;
        if(res==0) res=9;
        cout<<res<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81298504
今日推荐