HDU ACM1013——Digital Roots

Digital Roots

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

题目大意:如果所给数字大于10,求其各位数字之和,直到所得数字小于10.
注意:这个数字很大,必须用字符串来储存。

#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
    int i,root;
    char str[10001];
    while(scanf("%s",str)!=EOF){
        if(str[0]=='0')break;
        root=0;     //计数器归零 
        for(i=0; i<strlen(str); i++)    //求所给数字各位和 
            root+=(str[i]-'0');      
        while(root>=10)         //不断循环使root仅余个位 
            root=root/10 + root%10; 
        printf("%d\n",root);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/BarisGuo/article/details/82049985