Currency Exchange (Bellman-Ford)

Currency Exchange

 
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C  AB, R  BA and C  BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10  4
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES

题目大意:

有n种货币,有m种换法,现有货币为s,有v个单位的s币。接下来的m行为a,b,ar(a->b的汇率),ac(a->b的佣金),br(b->a的汇率),bc(b->a的佣金)。现在要通过换币来使拥有的钱变多,如果能就输出YES,不能就输出NO。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 105
using namespace std;
int n,m,s,k;
double v,dis[N];
struct node
{
    int a,b;
    double r,c;
}e[2*N];
int B_Ford()
{
    memset(dis,0,sizeof(dis));
    dis[s]=v;
    int flag=0;
    for(int i=1;i<=n;i++)
    {
        flag=0;
        for(int j=0;j<k;j++)
            if(dis[e[j].b]<(dis[e[j].a]-e[j].c)*e[j].r)
        {
            dis[e[j].b]=(dis[e[j].a]-e[j].c)*e[j].r;
            flag=1;
        }
        if(!flag)
            break;
    }
   if(flag)
    return 1;
    return 0;
}
int main()
{
    int a,b;
    double ar,ac,br,bc;
    scanf("%d%d%d%lf",&n,&m,&s,&v);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%lf%lf%lf%lf",&a,&b,&ar,&ac,&br,&bc);
        e[k].a=a,e[k].b=b,e[k].r=ar,e[k++].c=ac;
        e[k].a=b,e[k].b=a,e[k].r=br,e[k++].c=bc;
    }
    if(B_Ford())
        printf("YES\n");
    else
        printf("NO\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/79971218