POJ1860 Currency Exchange(Bellman)

POJ1860 Currency Exchange(Bellman)

Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES

题意

Bellman算法裸题,求出是否存在负圈即可,存在则输出YES,否则输出NO

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<functional> 
#include<map>
//#include<unordered_map>
#define lowbit(x) ((x)&-(x));
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N=1e5+10,NN=1e4+10,INF=0x3f3f3f3f,LEN=110;
const ll MOD=1e9+7;
const ull seed=31;
int n,m,s,sum;
double v;
struct Edge{
	int u,v;
	double rab,cab;//rab为佣金,cab为汇率 
}edge[N];
void bellman(){
	double d[N];
	for(int i=1;i<=n;i++) d[i]=0;
	d[s]=v;
	int k=0;
	bool update=true;
	while(update){
		k++;
		update=false;
		if(k>n){
			printf("YES\n");
			return ;
		}
		for(int i=1;i<=sum;i++){
			int x=edge[i].u,y=edge[i].v;
			if(d[y]<(d[x]-edge[i].rab)*edge[i].cab){
				update=true;
				d[y]=(d[x]-edge[i].rab)*edge[i].cab;
			}
		}
	}
	printf("NO\n");
	return ;
}
void init(){

}
int main(){
	scanf("%d%d%d%lf",&n,&m,&s,&v);
	sum=0;
	for(int i=1;i<=m;i++){
		int u,v;
		double rab,cab,rba,cba;
		scanf("%d%d%lf%lf%lf%lf",&u,&v,&cab,&rab,&cba,&rba);
		edge[++sum].u=u;
		edge[sum].v=v;
		edge[sum].cab=cab;
		edge[sum].rab=rab;
		edge[++sum].u=v;
		edge[sum].v=u;
		edge[sum].cab=cba;
		edge[sum].rab=rba;
	}
	bellman();
}

猜你喜欢

转载自blog.csdn.net/Hc_Soap/article/details/107722265