Currency Exchange(Bellman-Ford,判断正权回路)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意:

第一行输入货币的种类数n,交换点m,nick所持有的货币的种类s,以及nick现在的货币数目v;

接下里m行分别输入a,b,c,d,e,f,表示a换成b的汇率为c,佣金为d,b换成a的汇率为e,佣金为f。

问你nick通过兑换不同的种类,能否使钱增多,即判断是否存在正权回路。

解题思路:

一种货币就是一个点,一个“兑换点”就是图上两种货币之间的一个兑换方式,是双边,但A到B的汇率和手续费可能与B到A的汇率和手续费不同。

本题用的是Bellman-Ford,与判断负权回路不用的是,负权回路dis数组初始化最大,而这个判断正权回路是把dis数组初始化为0即可。

代码:

#include <stdio.h>
#include <string.h>
int a[110],b[110];
double c[110],d[110],e[110],f[110],dis[110];

int main()
{	
	double v;
	int n,m,s;
	int i,j,flag,check;
	while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=EOF)
	{
		for(i=1;i<=n;i++)
			dis[i]=0;
		dis[s]=v;
		for(i=1;i<=m;i++)
			scanf("%d%d%lf%lf%lf%lf",&a[i],&b[i],&c[i],&d[i],&e[i],&f[i]);
		for(i=1;i<n;i++)
		{
			check=0;
			for(j=1;j<=n;j++)
			{
				if(dis[b[j]]<(dis[a[j]]-d[j])*c[j]){
					dis[b[j]]=(dis[a[j]]-d[j])*c[j];
					check=1;
				}
				if(dis[a[j]]<(dis[b[j]]-f[j])*e[j]){
					dis[a[j]]=(dis[b[j]]-f[j])*e[j];
					check=1;
				}	
			}
			if(check==0)
				break;
		}
		flag=0;
		for(i=1;i<=m;i++)
		{
			if(dis[b[i]]<(dis[a[i]]-d[i])*c[i]){
				flag=1;
				break;
			}
			if(dis[a[i]]<(dis[b[i]]-f[i])*e[i]){
					flag=1;
					break;
			}	
		}
		if(flag==1)
			printf("YES\n");
		else 
			printf("NO\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81262299