Currency Exchange

题目:

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R  AB, C  AB, R  BA and C  BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10  4
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES


题意:

给出已知能够兑换的货币种类,以及更换货币的地方,当然这些地方只能更换两种相互的货币。兑换货币也是有代价的,需要交一定的手续费,很容易理解就是在判断路径的时候多一步操作;

分析:

从题意很容易知道,就是让我们判断有没有正环存在,用Dijstra很容易就可以判断

代码:

#include<stdio.h>
using namespace std;
int a[222],b[222];
double c[222],d[222],dis[111];
int n,m,s,total;
double v;
bool deal()
{
    int i,j;
    bool flag;
    for(i=1;i<=n;i++)
        dis[i]=0;
    dis[s]=v;
    for(i=1;i<n;i++)
    {
        flag=false;
        for(j=1;j<=total;j++)
        {
            if(dis[b[j]]<(dis[a[j]]-d[j])*c[j])
            {
                flag=true;
                dis[b[j]]=(dis[a[j]]-d[j])*c[j];
            }
        }
        if(!flag) return false;
    }
    for(i=1;i<=total;i++)
        if(dis[b[i]]<(dis[a[i]]-d[i])*c[i])
        return true;
    return false;
}
int main()
{
    int i,j,A,B,flaag=0;
    double C,D,E,F;
    scanf("%d %d %d %lf",&n,&m,&s,&v);
    total=1;
    while(m--)
    {
        scanf("%d %d %lf %lf %lf %lf",&A,&B,&C,&D,&E,&F);
        a[total]=A;
        b[total]=B;
        c[total]=C;
        d[total]=D;
        total++;
        a[total]=B;
        b[total]=A;
        c[total]=E;
        d[total]=F;
        total++;
    }
    deal();
    if(deal())
        printf("YES\n");
    else
        printf("NO\n");
    return 0;
}








/*将此题中的以每种货币的存在形式的钱用dis表示,换钱的地方就是路径,实际上
就是求最长路径,根据负环可以知到就是看有没有正环的存在,那么我们只需要将
第三种算法反过来即可,判断是否有正环*/

猜你喜欢

转载自blog.csdn.net/stdio_xuege/article/details/81065137