POJ 1860 Currency Exchange(SPFA)

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 36221   Accepted: 13905

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意:有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到(100 - 0.39) *      29.75 = 2963.3975 B币。问s币的金额经过交换最终得到的s币金额数能否增加

     货币的交换是可以重复多次的,所以我们需要找出是否存在正权回路,且最后得到的s金额是增加的

     怎么找正权回路呢?(正权回路:在这一回路上,顶点的权值能不断增加即能一直进行松弛)

解题思路:单源最短路径算法,因为题目可能存在负边,所以用Bellman Ford算法,

     原始Bellman Ford可以用来求负环,这题需要改进一下用来求正环

     本题是“求最大路径”,之所以被归类为“求最小路径”是因为本题题恰恰与bellman-Ford算法的松弛条件相反,

     求的是能无限松弛的最大正权路径,但是依然能够利用bellman-Ford的思想去解题。

     因此初始化dis(S)=V   而源点到其他点的距离(权值)初始化为无穷小(0),当s到其他某点的距离能不断变大时,

     说明存在最大路径;如果可以一直变大,说明存在正环。判断是否存在环路,用Bellman-Ford和spfa都可以。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define MAX 105
double dis[MAX],rate[MAX][MAX],cost[MAX][MAX];
int n,m,s;
int cnt[MAX],vis[MAX];
double v;
using namespace std;

int SPFA(int st)
{
	memset(vis,0,sizeof(vis));
	memset(cnt,0,sizeof(cnt));
	memset(dis,0,sizeof(dis));
	int i;
	queue<int>q;
	dis[st]=v;
	vis[st]=1;
	cnt[st]++;
	q.push(st);
	while(!q.empty())
	{
		int x=q.front();
		q.pop();
		vis[x]=0;
		for(i=1;i<=n;i++)
		{
			if(dis[i]<(dis[x]-cost[x][i])*rate[x][i]) //这里和负权回路相反 
			{
				dis[i]=(dis[x]-cost[x][i])*rate[x][i];
			//	if(dis[i]>v) return 1;
				if(!vis[i])
				{
					q.push(i);
					vis[i]=1;
					cnt[i]++;
				}
				if(cnt[i]>n) return 1;  //cnt表示i点入队的次数,如果次数大于n也就是循环了一个圈,即有正权回路 
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,a,b;
	double rab,cab,rba,cba;
	while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=EOF)
	{
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			if(i==j) rate[i][j]=1;
			else rate[i][j]=0;
			cost[i][j]=0;
		}
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%lf%lf%lf%lf",&a,&b,&rab,&cab,&rba,&cba);
			rate[a][b]=rab;
			cost[a][b]=cab;
			rate[b][a]=rba;
			cost[b][a]=cba;
			
		}
	if(SPFA(s)) printf("YES\n");
	else printf("NO\n");
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/zvenWang/article/details/81428667