【HDU 1070】Milk(贪心)

Milk

Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.


Sample Input
2
2
Yili 10 500
Mengniu 20 1000
4
Yili 10 500
Mengniu 20 1000
Guangming 1 199
Yanpai 40 10000

Sample Output
Mengniu
Mengniu

Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.
In the second case,milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.


题意:

Ignatius买牛奶,他对喝牛奶要求比较高:
1.他每天喝且仅喝200ml牛奶
2.无论一盒牛奶有多少,他都只喝5天
3.因为懒,因此小于200ml的牛奶他都屑于买(懒得天天跑超市啊)
4.喝到最后一天牛奶如果剩下小于200ml,他会扔掉不喝。
超市有很多种牛奶,每个价格、容量都不一样。请你帮他求出对他(的要求)来说最便宜的牛奶。

思路:

此题按照 喝牛奶 每天所需要花的钱数 rate 来进行从小到大排序,若钱数一样,则按照容量 从大到小排序。
根据要求,对牛奶容量(<200ml和>1000ml)的分别做特殊处理。<200ml不计入数组(便于排序),>1000ml和只喝5天的价值一样(即每天所花的钱数为总价值/5,剩余的浪费掉了)。
其他情况只需要用总容量/200算出能够喝的天数,再用总价值/天数即可。
最后按照上述规则对排序,数组第一个元素即为所求。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAX 105
using namespace std;
struct Milk{
    char name[MAX];
    int price;
    int vol;
    double rate;
}milk[MAX];

bool cmp(struct Milk a,struct Milk b)
{
     if(a.rate==b.rate) return a.vol>b.vol;
     else return a.rate<b.rate;
}

int main()
{
    int T,n;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
        {
            int tp,tv;
            char tname[MAX];
            cin>>tname>>tp>>tv;
            if(tv<200)
            {
                i--;
                n--;
            }
            if(tv>=200)
            {
                strcpy(milk[i].name,tname);
                milk[i].price=tp;
                milk[i].vol=tv;
                int day=milk[i].vol/200;
                if(milk[i].vol>=1000) milk[i].rate=(1.0*milk[i].price)/5;
                else milk[i].rate= (1.0 *milk[i].price)/day;
                //cout<<milk[i].rate<<endl;
            }
        }
        sort(milk,milk+n,cmp);
        cout<<milk[0].name<<endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_yuazzy/article/details/77522805