HDU-1070,Milk(结构体)

Problem Description:

Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest. 

Input: 

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle. 

Output: 

For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume. 

Sample Input: 

2

2

Yili 10 500

Mengniu 20 1000

4

Yili 10 500

Mengniu 20 1000

Guangming 1 199

Yanpai 40 10000 

Sample Output: 

Mengniu

Mengniu

Hint

In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.

 解题思路:

1. Ignatius永远不会喝6天或更早之前生产的牛奶。这意味着,如果牛奶是在2005-1-1年间生产的,那么Ignatius将永远不会在2005-1-6(含)后饮用此瓶。
2. Ignatius每天喝200mL牛奶。
3.如果瓶中剩余的牛奶少于200mL,Ignatius会将其丢弃。
4.超市里的所有牛奶今天才生产。
请注意,Ignatius只想购买一瓶牛奶,因此,如果一瓶的体积小于200mL,则应忽略它。
给定一些牛奶的信息,您的任务是告诉Ignatius哪种牛奶最便宜。 (具体的我们看代码)

 程序代码:

#include<bits/stdc++.h>
using namespace std;
struct Milk
{
	char name[1001];
	int p,v;
}milk[1001];
int main()
{
	int n,flag,t;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&t);
		double m=0;
		for(int i=0;i<t;i++)
		{
			scanf("%s%d%d",milk[i].name,&milk[i].p,&milk[i].v);
			int ans=0;
			if(milk[i].v<200)//容积小于200ml 
				continue;//直接舍弃 
			while(1)
			{
				milk[i].v-=200;//每天喝掉200ml 
				ans++;//天数+1 
				if(ans==5)//经过五天之后,不再喝 
					break;
				if(milk[i].v<200)//容积小于200ml 
					break;
			}
			double k=(double)ans/milk[i].p;//性价比:总的天数除以一瓶的价格 
			if(k>=m)
			{
				if(k>m)//选取性价比大的 
				{
					m=k;
					flag=i;
				}
				if(k==m)//如果性价比相同 
				{
					if(milk[i].p<milk[flag].p)//选取价格便宜的 
						flag=i;
					else if(milk[i].p==milk[flag].p)//如果价格相同 
					{
						if(milk[i].v>milk[flag].v)//选取容积较大的 
							flag=i;
					}
				}
			}
		}
		printf("%s\n",milk[flag].name);
	}
	return 0;
}
发布了274 篇原创文章 · 获赞 282 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/104069183