hdu1070 Milk

Milk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21438    Accepted Submission(s): 5738


Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
 

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 

Sample Input
 
  
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
 

Sample Output
 
  
Mengniu Mengniu
Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
 

/*
 * 平均价格=价格/可以饮用天数,将平均价格比由小到大排序,取平均价格最小的
 * 当平均价格相等时,取容量大的
 */

//
// Created by Admin on 2017/4/7.
//

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct MILK{
    double p;  //保持平均价格
    int v;
    char brand[110];
}milk[110];

double cmp(MILK a,MILK b){
    return a.p<b.p;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n,b,k=0;
        double a;
        char c[110];
        scanf("%d",&n);
        for (int i = 0; i < n; ++i){
            scanf("%s %lf %d",c,&a,&b);
            if(b>=200){
                milk[k].v=b;
                strcpy(milk[k].brand,c);
                if(b/200>5)milk[k].p=a/5;  //计算平均价格
                else milk[k].p=a/(b/200);
                k++;
            }
        }
        sort(milk,milk+k,cmp);
        int ans=0;
        for (int j = 1; j < k; ++j)  //当平均价格相等时,取容量大的
            if(milk[j].p==milk[ans].p && milk[j].v>milk[ans].v)ans=j;
        puts(milk[ans].brand);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_32767041/article/details/69589665