hdu 4296 Buildings(贪心)

Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5348    Accepted Submission(s): 1910


Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
 
  
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
 
  
1 0 2
 

Source
 

Recommend
liuyiding

题意:

有n个层楼,每一层都有它自己的w和s值,定义PDV=在这层楼上的所有w的和减去这层楼的s值。

问如何摆放才能让PDV有最小值。

思路:

假设i,j(j=i+1)这两层相邻前面有若干层,设前面的w和为sum,

那么两个楼层如果交换顺序那么他们的PDV分别为

sum+wi-sj  和   sum+wj-si

我们让sum+wi-sj<sum+wj-si

得到wi-sj<wj-si

按照这样的排序就能够使得排在最后的那个楼层具有最小的PDV

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
struct node
{
    int w,s;
}q[maxn];
bool cmp(node a,node b)
{
    return a.w-b.s<b.w-a.s;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&q[i].w,&q[i].s);
        }
        sort(q+1,q+1+n,cmp);
        long long sum=0;
        for(int i=1;i<=n-1;i++)
            sum+=q[i].w;
        printf("%lld\n",sum-q[n].s);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/timeclimber/article/details/80056586