#BFS# POJ1985 Cow Marathon(树的直径)

POJ 1985

Description
After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input
* Lines 1…..: Same input format as “Navigation Nightmare”.
Output
* Line 1: An integer giving the distance between the farthest pair of farms.
Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
Sample Output
52
Hint
The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.

题目大意:

在一棵树上寻找相距最远的两个点的距离

解题思路:

树上面求最长简单路(无环)就是求树的直径,两边BFS即可

  • 第一次任取一个点搜索查找出最远距离的点u(u点一定是最长路的一个端点)
  • 第二次则从第一次找到的点u找出距离点u最远距离的点v(v即是最长路的另一个端点),u, v两点的距离即是树的直径

代码:

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
typedef long long LL;
const int MaxN = 1e5 + 5;

struct EDGE {
    int to, nxt, c;
} edge[MaxN];

int n, m, ans, sx, num = 0;
int vis[MaxN], dist[MaxN], head[MaxN];

void build(int u, int v, int c) {
    edge[num].to = v;
    edge[num].c = c;
    edge[num].nxt = head[u];
    head[u] = num++;
}
void bfs(int st) {
    memset(dist, 0, sizeof(dist));
    memset(vis, 0, sizeof(vis));
    queue<int> q;
    q.push(st);
    vis[st] = 1, ans = 0;
    while(!q.empty()) {
        int u = q.front(); q.pop();
        for(int i = head[u]; i != -1; i = edge[i].nxt) {
            int v = edge[i].to;
            if(!vis[v]) {
                vis[v] = 1;
                dist[v] = dist[u] + edge[i].c;
                if(ans < dist[v]) {
                    ans = dist[v]; 
                    sx = v;
                }
                q.push(v);
            }
        }
    }
}
int main() {
    scanf("%d %d", &n, &m);
    memset(head, -1, sizeof(head));
    while(m--) {
        int u, v, c; char s[5];
        scanf("%d %d %d %s", &u, &v, &c, s);
        build(u, v, c);
        build(v, u, c);
    }
    bfs(1);
    bfs(sx);
    cout << ans << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jasmineaha/article/details/79548763