POJ - 1985 Cow Marathon

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52
扫描二维码关注公众号,回复: 5080721 查看本文章

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

题目大意:求两个农场之间的最大距离; 

解题思路: 树的直径,每一行最后免得字母不用管没什么用

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1e6;

struct edge{
	int to;
	int w;
	int next;
}e[maxn];

int head[maxn];
int cnt,point,ans;

void init()
{
	cnt=0;
	ans=0;
	memset(head,-1,sizeof(head));
}

void add(int u,int v,int w)
{
	e[cnt].to=v;
	e[cnt].w=w;
	e[cnt].next=head[u];
	head[u]=cnt++;
}

void dfs(int u,int pre,int w)
{
	if(w>ans)
	{
		ans=w;
		point=u;
	}
	for(int i=head[u];~i;i=e[i].next)
	{
		int to=e[i].to;
		if(to!=pre)
			dfs(to,u,w+e[i].w);
	} 
}
int main()
{
	int m,n,u,v,w;
	char c;
	while(cin>>n>>m)
	{
		init();
		for(int i=0;i<m;i++)
		{
			cin>>u>>v>>w>>c;
			add(u,v,w);
			add(v,u,w);
		}
		dfs(1,-1,0);
		ans=0;
		dfs(point,-1,0);
		cout<<ans<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/86656495