poj1985 树的直径 两次dfs

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 
 
 
建树,从任意一个点开始dfs 找到最远点 记录
再从这个最远点 开始dfs 直到最远点的距离 就是直径
 
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
const int maxn=1e5+10;
int maxx=0;
int p;
struct node{
	int y;
	int len;
	node(int yy,int lenn){
		y=yy,len=lenn;
	}
};
vector<node> s[maxn];
void dfs(int u ,int fa, int dis ){
	for(int i=0;i<s[u].size();i++){
		int v=s[u][i].y;
		int len=s[u][i].len;
		if(v==fa)  continue;
		dfs(v,u,dis+len);
	}
	if(  dis > maxx ){
		maxx=dis,p=u;
	}
}

int main(){
	int n,m;
	while(~scanf("%d%d",&n,&m)){
		for(int i=0;i<m;i++){
			int a,b,c;
			char d;
			scanf("%d %d %d %c",&a,&b,&c,&d);
			s[a].push_back(node(b,c));
			s[b].push_back(node(a,c));
		}
		dfs(1,1,0);
		maxx=0;
		dfs(p,p,0);
		printf("%d\n",maxx);
	}
	return 0;
}

  

 

猜你喜欢

转载自www.cnblogs.com/lyj1/p/11369200.html
今日推荐