POJ - 1985 G - Cow Marathon【树的直径】

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

求树的直径

code:

#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
const int maxn=100020;
using namespace std;
int dis[maxn],ans;
bool vis[maxn];
vector<pair<int,int> > V[maxn];
int bfs(int x)
{
	ans=0; //每次清0 
    memset(dis,0,sizeof(dis));
    memset(vis,0,sizeof(vis));
    queue<int>Q;
    Q.push(x);
    vis[x]=1;
    int point=0;
    while(!Q.empty())
    {
        int F=Q.front();
        Q.pop();
        if(dis[F]>ans)
        {
            ans=dis[F];
            point=F;
        }
        pair<int,int>t;
        for(int i=0;i<V[F].size();i++)
        {
             t=V[F][i];//v[F]是个vector,里面有多个pair<int,int>
             if(vis[t.first]==0)
             {
                vis[t.first]=1;
                dis[t.first]=dis[F]+t.second;
                Q.push(t.first);
             }
        }
    }
    return point;
}
int main()
{
    int N,M,x,y,z;
    char dir;
    while(cin>>N>>M)
    {
        for(int i=0;i<M;i++)
        {
            cin>>x>>y>>z>>dir;//x y两个相连的顶点 z权值 
            V[x].push_back(make_pair(y,z));//邻接表存图 
            V[y].push_back(make_pair(x,z));
        }
        int point=bfs(1);//从任意一个点开始找离它最远点 
        bfs(point);//从刚才找到的最远点再找离它最远的点得到 ans 
        cout<<ans<<endl;
        for(int i=0;i<=N;i++)
            V[i].clear();//清空 
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81428049