Cow Marathon (树的直径)

 Cow Marathon

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

题意:给一个无向连通图,在不重复的情况下,问能走的最大的长度是多少。

题解:树的直径,模板题。

下面是AC代码

//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int O    =  1e5;
const int mod  =  1e9+7;
const int maxn =  1e6+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;

struct dd{
    int to , vul;
};
int dis[maxn];
int vis[maxn];
int ans , pos;
int n , m ;
vector<dd>ve[maxn];

void bfs(int st){
    ans = 0;
    queue<int>Q; Q.push(st);
    MT(dis, 0); MT(vis, 0);
    vis[st] = true;
    while(!Q.empty()){
        int u = Q.front();   Q.pop();
        if(dis[u] > ans ) {
            ans = dis[u]; pos = u;
        }
        for(int i=0; i<ve[u].size(); i++){
            int v =  ve[u][i].to;
            if(!vis[v]){
                vis[v] = true;
                dis[v] = dis[u] + ve[u][i].vul;
                Q.push(v);
            }
        }
    }
}

int main(){
    scanf("%d%d",&n,&m);
    while(m--){
        int fm, to, v; char c;
        scanf("%d%d%d %c",&fm, &to, &v, &c);
        ve[fm].push_back({to, v});
        ve[to].push_back({fm, v});
    }
    bfs(1);  bfs(pos);
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/82828398