[POJ 1985][树的直径]Cow Marathon

题目描述:
题目链接: POJ 1985 Cow Marathon
After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input:
* Lines 1…..: Same input format as “Navigation Nightmare”.
Output:
* Line 1: An integer giving the distance between the farthest pair of farms.
Sample Input:
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
Sample Output:
52
Hint:
The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.
题目大意:
在一片土地上有很多农场,其中相连的两个农场的距离已给出,求两个农场之间最远的距离。
题目分析:
这是一道求树的直径的模板题。
如果不会可看我的讲解:树的直径求法及证明
下附代码是两次dfs求直径,也可以用bfs.。
PS:吐槽一下,这道题题面根本没有给数据范围。
附代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cstdio>
#include<ctime>
#include<cmath>
#include<cctype>
#include<iomanip>
#include<algorithm>
using namespace std;

const int N=1e5+10;
int tot,n,m,nxt[N],dis[N],to[N],first[N],w[N],v,maxd,po;
char c;

void create(int x,int y,int z)
{
    tot++;
    nxt[tot]=first[x];
    first[x]=tot;
    to[tot]=y;
    w[tot]=z;
}

void dfs(int u,int fa)
{
    for(int e=first[u];e;e=nxt[e])
    {
        v=to[e];
        if(v!=fa)
        {
            dis[v]=dis[u]+w[e];
            if(dis[v]>maxd){maxd=dis[v];po=v;}
            dfs(v,u);
        }
    }
}

int main()
{
    //freopen("lx.in","r",stdin);

    int x,y,z;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d %c\n",&x,&y,&z,&c);
        create(x,y,z);
        create(y,x,z);
    }
    dis[1]=0;
    dfs(1,0);
    dis[po]=0;
    dfs(po,0);
    printf("%d",maxd);

    return 0;
}
发布了99 篇原创文章 · 获赞 8 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qianguch/article/details/78217030