树的直径典型 Cow Marathon _______http://poj.org/problem?id=1985

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

题意:让你在一个图里求出最长的两点的距离

图中求树上最长的距离,用到树的直径的原理:

树上最长的简单路径即为树的直径。

求树的直径的方法就是在树上任选一点u,求距离点u最远的点y,再求距离点y最远的点s,点y到点s的距离即为树的直径。

 

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>


using namespace std;
typedef long long LL;
const int maxn = 1e5 + 5;

typedef pair <int, int> PIL;

vector <PIL> v[maxn];
int vis[maxn];
int dis[maxn];
int n, m;
int ans, s;

void dfs(int xx)
{
	vis[xx] = 1;
	if(dis[xx] > ans)
	{
		ans = dis[xx];
		s = xx;
	}
	for(int i = 0; i < v[xx].size(); i++)
	{
		int ed = v[xx][i].first;
		int w = v[xx][i].second;
		if(!vis[ed])
		{
			dis[ed] = dis[xx] + w;
			dfs(ed);
		}
	}
	return;
}

int main()
{
	while(~scanf("%d%d", &n, &m))
	{
		for(int i = 1; i <= m; i++)
		{
			int x, y, l;
			char c;
			scanf("%d %d %d %c", &x, &y, &l, &c);
			v[x].push_back(make_pair(y, l));
			v[y].push_back(make_pair(x, l));
		}
		ans = 0;
		s = -1;
		memset(vis, 0, sizeof(vis));
		memset(dis, 0, sizeof(dis));
		dfs(1);
		ans = 0;
		memset(vis, 0, sizeof(vis));
		memset(dis, 0, sizeof(dis));
		dfs(s);
		for(int i = 1; i <= n; i++) v[i].clear();
		printf("%d\n", ans);
	}
	return 0;
}

 

猜你喜欢

转载自blog.csdn.net/strawberry_595/article/details/81087688