PAT甲级-1070 Mooncake(25 分)【贪心】

1070 Mooncake(25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

解题思路:只要看懂题目,这题就很简单,我们用数据结构来存储相应的数据,还把它们对应的单价算出,然后将他们按照单价的大小排序,从大到小排序,然后就一个for循环,一旦数量大于demand就跳出循环,输出相应的价格。

#include<bits/stdc++.h>
using namespace std;
struct Mooncake{
	double weight,price,unit;
};

bool cmp(Mooncake a,Mooncake b)//从大到小排序
{
	return a.unit>b.unit;
}
int main(void)
{
	int n,d;
	scanf("%d%d",&n,&d);
	vector<Mooncake>m(n);
	for(int i=0;i<n;i++)
	scanf("%lf",&m[i].weight);
	for(int i=0;i<n;i++)
	scanf("%lf",&m[i].price);
	for(int i=0;i<n;i++)
	m[i].unit=m[i].price/m[i].weight;
	sort(m.begin(),m.end(),cmp);
	double ans=0;
	for(int i=0;i<n;i++)
	{
		if(m[i].weight<=d)  ans=ans+m[i].price;
		else
		{
			ans=ans+d*m[i].unit;//一旦满足条件就退出循环
			break;
		}
		d=d-m[i].weight;
	}
	printf("%.2lf",ans);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82316215