PAT(甲级)1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题目大意:给定图的顶点个数和边个数,给定起始点和终点,然后给出各个节点的权值和各边的权值,求从起始到目标点的边的权值和最小的路径的条数以及输出经过的顶点的权值之和最大的值。

(这道题主要是考察Dijkstra算法,奈何水平有限,所以参考了柳神的代码,还是得继续学习啊)

#include<iostream>
#include<algorithm>
using namespace std;
int n, m, c1, c2;
int e[510][510],weight[510],dis[510],num[510],w[510];
bool visit[510];
const int inf = 999999999;
int main()
{
    cin >> n >> m >> c1 >> c2;
    for (int i = 0; i < n;i++)
        cin >> weight[i];
    fill(e[0], e[0] + 510 * 510, inf);
    fill(dis, dis + 510, inf);
    int a,b,c;
    for (int i = 0; i < m;i++)
    {
        cin >> a >> b >> c;
        e[a][b] = e[b][a] = c;
    }
    dis[c1] = 0;        //dis[i]存放从出发点到结点i的路径长度
    w[c1] = weight[c1]; //w[i]表示从出发点到结点i的路径上权值之和
    num[c1] = 1;        //num[i]表示从出发点到i的路径的条数
    for (int i = 0; i < n;i++)
    {
        int u = -1, minn = inf;
        for (int j = 0;j<n;j++)
        {
            if(visit[j] == false && dis[j]<minn)
            {
                u = j;
                minn = dis[j];
            }
        }
        if(u == -1)
            break;
        visit[u] = true;
        for (int v = 0; v < n; v++)
        {
            if(visit[v] == false && e[u][v] != inf)
            {
                if(dis[u] + e[u][v] <dis[v])
                {
                    dis[v] = dis[u] + e[u][v];
                    num[v] = num[u];
                    w[v] = w[u] + weight[v];
                }
                else if(dis[u] + e[u][v] == dis[v])
                {
                    num[v] = num[v] + num[u];
                    if(w[u] + weight[v] > w[v])
                        w[v] = w[u] + weight[v];
                }
            }
        }
    }
    cout << num[c2] << ' ' << w[c2];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35601980/article/details/88661241
今日推荐