PAT 甲级 2019年春季三月份 7-3 Telefraud Detection (25 分)

Telefraud(电信诈骗) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.

A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. A makes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.

Input Specification:

Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(阈值) of the amount of short phone calls), N (≤103, the number of different phone numbers), and M (≤105, the number of phone call records). Then M lines of one day’s records are given, each in the format:

caller receiver duration

where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.

Output Specification:

Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

If no one is detected, output None instead.

Sample Input 1:

5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1

Sample Output 1:

3 5
6

Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1 had made 5 short phone calls and didn’t exceed the threshold 5, and therefore is not a suspect.

Sample Input 2:

5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1

Sample Output 2:

None

这道题主要考察并查集,其次就是堆stl的熟练使用,难度不大,第一次没做出来的,建议去搜一下并查集的知识,把并查集弄懂,这是一个非常重要的知识点。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int K,N,M;
const int maxn=1005;
int calls[maxn][maxn]={0};
vector<int> sus;// 诈骗团伙
vector<int> gang[maxn];
int par[maxn];
int getPar(int a)
{
    if(par[a]==a)
        return a;
    else
        return par[a] = getPar(par[a]);
}
void Union(int a,int b)
{
    int x=getPar(a);
    int y=getPar(b);
    if(x>y)
        swap(x,y);
    par[y]=x;//b的父节点是a
}

int main()
{
    cin>>K>>N>>M;
    int a,b,c;
    for(int i=1;i<=M;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        calls[a][b]+=c; //a给b打电话,通话时间为c
    }
    for(int i=1;i<=N;i++)
    {
        int num=0;
        int call_back=0;
        for(int j=1;j<=N;j++)
            if( calls[i][j]!=0 && calls[i][j] <=5 ) //打过电话,并且总通话时间不大于5
            {
                num++;
                if( calls[j][i]!=0 ) //回了电话
                    call_back++;
            }
        if( num>K && call_back*5<=num  )
            sus.push_back(i); //i是犯罪嫌疑人
    }
//以下开始堆犯罪团伙进行归并,考察并查集
    if( sus.empty() )
    {
        printf("None\n");
        return 0;
    }
    for(int i=1;i<=N;i++) //初始化
        par[i]=i;
    for(int i=0;i<sus.size();i++)
        for(int j=i+1;j<sus.size();j++)
        {
            a=sus[i];
            b=sus[j];
            if( calls[a][b]!=0 && calls[b][a]!=0 ) //互相通过电话,是一伙的
                Union(a,b);
        }
    for(int i=0;i<sus.size();i++)
        gang[ getPar(sus[i]) ].push_back(sus[i]);
    for(int i=1;i<=N;i++)
        if(!gang[i].empty())
        {
            sort(gang[i].begin(),gang[i].end());
            for(int j=0;j<gang[i].size();j++)
                printf("%d%c",gang[i][j],j==gang[i].size()-1?'\n':' ');
        }
    return 0;
}

发布了174 篇原创文章 · 获赞 18 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_41173604/article/details/100608852