The Preliminary Contest for ICPC Asia Shenyang 2019 C. Dawn-K's water(动态规划:完全背包)

传送门:https://nanti.jisuanke.com/t/41401

题目描述

Dawn-K recently discovered a very magical phenomenon in the supermarket of Northeastern University: The large package is not necessarily more expensive than the small package.

On this day, Dawn-K came to the supermarket to buy mineral water, he found that there are nn types of mineral water, and he already knew the price p p and the weight c c (kg) of each type of mineral water. Now Dawn-K wants to know the least money aa he needs to buy no less than mm kilograms of mineral water and the actual weight bb of mineral water he will get. Please help him to calculate them.

输入

The input consists of multiple test cases, each test case starts with a number n ( 1 n 1 0 3 n (1 \le n \le 10^3 ) – the number of types, and m ( 1 m 1 0 4 ) m (1 \le m \le 10^4) – the least kilograms of water he needs to buy. For each set of test cases, the sum of nn does not exceed 5 e 4 5e4

Then followed n lines with each line two integers p ( 1 p 1 0 9 ) p (1 \le p \le 10^9 ) – the price of this type, and c ( 1 c 1 0 4 ) c (1 \le c \le 10^4) – the weight of water this type contains.

输出

For each test case, you should output one line contains the minimum cost a a and the weight of water Dawn-K will get b b . If this minimum cost corresponds different solution, output the maximum weight he can get.

(The answer a is between 1 1 and 1 0 9 10^9 , and the answer b is between 1 and 1 0 4 10^4 )

样例输入

3 3
2 1
3 1
1 1
3 5
2 3
1 2
3 3

样例输出

3 3
3 6

按照题意,所有的水都可以无限次取,所以选择完全背包。
状态: d p [ i ] dp[i] 选到i重量时的最少价值 d p [ i ] = min ( d p [ i w ] + v , d p [ i ] ) dp[i] = \min(dp[i-w] +v, dp[i])
又因水可以取超过最低要求,所以背包的容量应该是最低标准m+最重的水的重量maxc,这是可能的最大的总重量。
接着迭代更新过后,遍历从最低标准m背包上限 m+maxc的dp[i],最小值即为答案。

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
 
const int maxn = 1e3 + 10;
const int maxm = 2e4 + 10;
int n, m, p, c, dp[maxm];
struct water { int p, c; } wat[maxn];
 
inline const int read()
{
    int x = 0, f = 1; char ch = getchar();
    while (ch < '0' || ch > '9') { if (ch == '-') f = -1; ch = getchar(); }
    while (ch >= '0' && ch <= '9') { x = (x << 3) + (x << 1) + ch - '0'; ch = getchar(); }
    return x * f;
}
 
int main()
{
    while (~scanf("%d%d", &n, &m))
    {
        memset(dp, 0x3f, sizeof(dp)); dp[0] = 0;
        int maxc = 0;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d%d", &wat[i].p, &wat[i].c);
            maxc = max(maxc, wat[i].c);
        }
        for (int i = 1; i <= n; i++)
            for (int j = wat[i].c; j <= m + maxc; j++)
                dp[j] = min(dp[j], dp[j - wat[i].c] + wat[i].p);
        int a = 1e9, b = 0;
        for (int i = m; i <= m + maxc; i++)
        {
            if (dp[i] <= a)
            {
                a = dp[i];
                b = i;
            }
        }
        printf("%d %d\n", a, b);
    }
    return 0;
}
发布了35 篇原创文章 · 获赞 15 · 访问量 1111

猜你喜欢

转载自blog.csdn.net/irimsky/article/details/101070807