Buy Watermelon (The Preliminary Contest for ICPC Asia Xuzhou 2019)

The hot summer came so quickly that Xiaoming and Xiaohong decided to buy a big and sweet watermelon. But they are two very strange people. They are even-numbered enthusiasts. They want to cut the watermelon in two parts, and each part weighs two times as much as a kilogram .They quickly decide which melon to buy. Do you know if you want to buy this melon?

Input

Only one line contains one integer w(1\leq w\leq 100)(1w100),units are kilograms.

Output

If it can meet the requirements, you will output YES, otherwise output NO.

样例输入

8

样例输出

YES
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int main()
{
    long long n;
    while(cin>>n)
    {
        if(n<4)
            cout<<"NO"<<endl;
        else if(n%2)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Shallow-dream/p/11482821.html