The Preliminary Contest for ICPC Asia Shenyang 2019 C. Dawn-K's water #完全背包 基础DP#

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_35850147/article/details/100857604

Portal

Dawn-K recently discovered a very magical phenomenon in the supermarket of Northeastern University: The large package is not necessarily more expensive than the small package.

On this day, Dawn-K came to the supermarket to buy mineral water, he found that there are nn types of mineral water, and he already knew the price pp and the weight cc (kg) of each type of mineral water. Now Dawn-K wants to know the least money aa he needs to buy no less than mm kilograms of mineral water and the actual weight bb of mineral water he will get. Please help him to calculate them.

Input

The input consists of multiple test cases, each test case starts with a number nn (1 \le n \le 10^31≤n≤103) -- the number of types, and mm (1 \le m \le 10^41≤m≤104) -- the least kilograms of water he needs to buy. For each set of test cases, the sum of nn does not exceed 5e45e4.

Then followed n lines with each line two integers pp (1 \le p \le 10^91≤p≤109) -- the price of this type, and cc (1 \le c \le 10^41≤c≤104) -- the weight of water this type contains.

Output

For each test case, you should output one line contains the minimum cost aa and the weight of water Dawn-K will get bb. If this minimum cost corresponds different solution, output the maximum weight he can get.

(The answer aa is between 11 and 10^9109, and the answer bb is between 11 and 10^4104)

样例输入

3 3
2 1
3 1
1 1
3 5
2 3
1 2
3 3

样例输出

3 3
3 6
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;

const int maxn = 1e3 + 10;
const int maxm = 2e4 + 10;
int n, m, p, c, dp[maxm];
struct water { int p, c; } wat[maxn];

inline const int read()
{
    int x = 0, f = 1; char ch = getchar();
    while (ch < '0' || ch > '9') { if (ch == '-') f = -1; ch = getchar(); }
    while (ch >= '0' && ch <= '9') { x = (x << 3) + (x << 1) + ch - '0'; ch = getchar(); }
    return x * f;
}

int main()
{
    while (~scanf("%d%d", &n, &m))
    {
        memset(dp, 0x3f, sizeof(dp)); dp[0] = 0;
        int maxc = 0;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d%d", &wat[i].p, &wat[i].c);
            maxc = max(maxc, wat[i].c);
        }
        for (int i = 1; i <= n; i++)
            for (int j = wat[i].c; j <= m + maxc; j++)
                dp[j] = min(dp[j], dp[j - wat[i].c] + wat[i].p);
        int a = 1e9, b = 0;
        for (int i = m; i <= m + maxc; i++)
        {
            if (dp[i] <= a)
            {
                a = dp[i];
                b = i;
            }
        }
        printf("%d %d\n", a, b);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/100857604