PAT A1045 Favorite Color Stripe (30分)

PAT甲级:A1045 Favorite Color Stripe (30分)

先引入我另一篇关于 最长不下降子序列 的笔记.

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7
  • 题意:Eva 要在一条颜色带选出她最喜欢的颜色,将其组成新的颜色带,题目给出 Eva 最喜欢的颜色以及排序,要求按照这个“最喜欢的颜色序列”来选择颜色(即选出的颜色可以不完全包含其最喜欢的颜色,但是必须按照她喜欢的顺序排列),并使组合出的颜色带最长,输出长度。(必须从颜色带的左到右依次选择,不能交替)。
  • 分析:这是 最长不下降子序列 问题,但是大小比较方式不能通过颜色的编号,需要根据 Eva 对某个颜色的喜欢程度比较,所以在读入时对 Eva 最喜欢的颜色通过排名重新编号,记录在number数组中,因为颜色带中可能包含 Eva 不喜欢的颜色,所以为了省去给多余颜色排名的步骤,在读入数据时候直接将这些多余的颜色过滤掉。
#include <bits/stdc++.h>
using namespace std;
int main() {
    int n, m, l, temp, dp[10010], number[210];
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= m; i++) {
        scanf("%d", &temp);
        number[temp] = i;
    }
    scanf("%d", &l);
    vector<int> a;
    for (int i = 0; i < l; i++) {
        scanf("%d", &temp);
        if (number[temp] != 0) a.push_back(temp);
    }
    int ans = -1;
    for (int i = 0; i < a.size(); i++) {
        dp[i] = 1;
        for (int j = 0; j < i; j++) {
            if (number[a[i]] >= number[a[j]] && dp[j] + 1 > dp[i]) {
                dp[i] = dp[j] + 1;
            }
        }
        ans = max(ans, dp[i]);
    }
    printf("%d", ans);
    return 0;
}
发布了27 篇原创文章 · 获赞 0 · 访问量 101

猜你喜欢

转载自blog.csdn.net/charjindev/article/details/104311796