1045 Favorite Color Stripe(30 分

1045 Favorite Color Stripe(30 分
Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10
​4
​​ ) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

解题思路:
最长不下降子序列或者最长公共子序列,参照算法笔记。

/*
//最长不下降子序列 
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
int a[maxn],pri[maxn],dp[maxn];
int main(){
    int n,m,l,x,cnt=0;
    fill(pri,pri+maxn,-1);
    scanf("%d",&n);
    scanf("%d",&m);
    for(int i=1;i<=m;i++){
        scanf("%d",&x);
        pri[x]=i;
    }
    scanf("%d",&l);
    for(int i=0;i<l;i++){
        scanf("%d",&x);
        if(pri[x]!=-1){
            a[cnt++]=pri[x];
        }
    }
    int ans=-1;
    for(int i=0;i<cnt;i++){
        dp[i]=1;
        for(int j=0;j<i;j++){
            if(a[i]>=a[j]&&dp[j]+1>dp[i]){
                dp[i]=dp[j]+1;
            }
        }
        ans=max(ans,dp[i]);
    }
    printf("%d\n",ans);
    return 0;
}
*/
//最长公共子序列
#include<cstdio> 
#include<algorithm>
using namespace std;
const int maxn=10010;
int a[maxn],b[maxn],dp[maxn][maxn];
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
        scanf("%d",&a[i]);
    int l;
    scanf("%d",&l);
    for(int i=1;i<=l;i++)
        scanf("%d",&b[i]);
    for(int i=0;i<=m;i++)
        dp[i][0]=0;
    for(int j=0;j<=l;j++)
        dp[0][j]=0;
    for(int i=1;i<=m;i++){
        for(int j=1;j<=l;j++){
            if(a[i]==b[j]) 
                dp[i][j]=max(dp[i][j-1],dp[i-1][j])+1;
            else
                dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
        }
    }
    printf("%d\n",dp[m][l]) ;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/chenyutingdaima/article/details/82080332