PAT A1045 Favorite Color Stripe (30point(s))

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7
  • 思路 1: 最长不下降子序列(Longest Increasing Sequence) LIS问题

将Eva 喜欢的颜色用has数组标记:下标越大,优先级越高,比如 2 3 1 5 6:对应has[] = 3 1 2 0 4 5;,其中,不喜欢的元素记为0;

遍历GIven:每到一个元素,先记dp[i] = 0 若该元素是Eva喜欢的,优化dp[i] = 1;若在此基础上,还可以优化(0~i中有可以和i构成合法子序列 并且 长度更长),优化:dp[i] = dp[j] +1;

用全局变量求出最长子序列的长度

  • code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;
int order[maxn], num[maxn], dp[maxn];
int main(){
	int n, m, tmp;
	scanf("%d %d", &n, &m);
	for(int i = 1; i <= m; ++i){	//Wrong 1: 样例2:要从1开始因为有的数字不存在,比如样例中的4,序号记为0 
		scanf("%d", &tmp);
		order[tmp] = i;
	}
	scanf("%d", &m);
	int Max = 0;
	for(int i = 0; i < m; ++i){
		scanf("%d", &tmp);
		num[i] = tmp;
		dp[i] = 0;
		if(order[tmp] != 0){	//当前颜色可取 
			dp[i] = 1;
			for(int j = 0; j < i; ++j){
				if(order[tmp] >= order[num[j]] && dp[j] + 1 > dp[i]) dp[i] = dp[j] + 1;
			}
			Max = max(Max, dp[i]);
		}
	}
	printf("%d", Max);
	return 0;
} 
  • code 2:
#include <bits/stdc++.h>
using namespace std;
const int colors = 250, amount = 10010;
int order[colors], given[amount], dp[amount];
// dp[i] = if(order[j] > order[i] && dp[1~j] + 1 > dp[j]);

int main(){
	int n, len1, len2, tmp;
	scanf("%d %d", &n, &len1);
	for(int i = 1; i <= len1; ++i){
		scanf("%d", &tmp);
		order[tmp] = i;
	}
	scanf("%d", &len2);
	int Max = 0;
	for(int i = 1; i <= len2; ++i){
		scanf("%d", &given[i]);
		for(int j = 0; j < i; ++j){	// j 从 0 开始比起 
			if(order[given[i]] != 0 && order[given[i]] >= order[given[j]] && dp[j] + 1 > dp[i]){
				dp[i] = dp[j] + 1;
			}
		}
	}
	printf("%d", dp[len2]);
	return 0;
}
  • 思路 2: 最长公共子序列(Longest Common Subsequence):LCS

状态转移方程:

dp[i][j] = 
1.  如果 v1[i] == v2[j]: max(dp[i-1][j-1], dp[i][j-1]) + 1; //因为第一个串在第二个串中可以重复
2.  如果 v1[i] != v2[j]: max(dp[i-1][j], dp[i][j-1]);	//回退到上一状态

边界:

dp[i][0] = 0;	// i from 0 to n
dp[0][j] = 0;	// j from 0 to n
#include <bits/stdc++.h>
using namespace std;
const int colors = 250;
const int maxn = 10010;
int dp[maxn][colors], f_color[colors], given[maxn];

int main(){
	int n, len1, len2, tmp;
	scanf("%d %d", &n, &len1);
	for(int i = 1; i <= len1; ++i){
		scanf("%d", &f_color[i]);
	}
	scanf("%d", &len2);
	for(int i = 1; i <= len2; ++i){
		scanf("%d", &tmp);
		given[i] = tmp;
		for(int j = 1; j <= len1; ++j){
			if(f_color[j] == tmp){
				dp[i][j] = max(dp[i-1][j-1], dp[i-1][j])+ 1;
			}else{
				dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
			}
		}
	}
	printf("%d", dp[len2][len1]); 
	return 0;
}
发布了271 篇原创文章 · 获赞 5 · 访问量 6520

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/104169297