PAT甲级 1045. Favorite Color Stripe (30)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10^​4​​ ) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

分析
做完后看题解发现都是LIS。
刚开始没认真看题,直接对两个数组dp,发现完全能做,还比LIS快。

#include <bits/stdc++.h>
using namespace std;

const int maxn = 10010;

int f[maxn][210];
int ss, m, l;  // m < l
int s[maxn], t[maxn];
int main()
{
    cin >> ss >> m;
    for (int i = 1; i <= m; i++)
        cin >> s[i];
    cin >> l;
    for (int i = 1; i <= l; i++)
        cin >> t[i];

    for (int i = 1; i <= m; i++)
    {
        for (int j = 1; j <= l; j++)
        {
            f[j][i] = max(f[j - 1][i], f[j][i-1]);
            if (t[j] == s[i]) f[j][i] += 1;
        }
    }
    cout << f[l][m] << endl;
    return 0;
}
发布了673 篇原创文章 · 获赞 644 · 访问量 38万+

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/90489231
今日推荐