ICPC北京2017 Pangu and Stones HihoCoder - 1636(区间DP)

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn’t be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer ‘0’.

Input
There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai <=1000,i= 1…N ), indicating the number of stones of pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

Output
For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output 0.

扫描二维码关注公众号,回复: 9092709 查看本文章

Sample Input
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
Sample Output
9
6
0

题意: n个石头,每次可以合并最少l堆,最多r堆。合并的代价是堆的价值和。求合并成一堆的最小价值
思路:
定义F[i][j][p]为合并i~j 的石头为p堆的最小代价。

转移的时候,一方面是要寻找合并为p堆的最小代价:
F[i][j][p] = min{F[i][k][1] + F[k+1][j][p-1]}.
另一方面要寻找合并成一堆的最小代价:
F[i][j][1] = min{F[i][j][p] + sum[j] - sum[i - 1]}. (p ≥ l)

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;
int a[105],sum[105];
int dp[105][105][105];

int main()
{
    int n,l,r;
    while(~scanf("%d%d%d",&n,&l,&r))
    {
        memset(dp,0x3f,sizeof(dp));
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i]);
            sum[i] = sum[i - 1] + a[i];
            dp[i][i][1] = 0;
        }
        
        for(int len = 1;len <= n;len++)
        {
            for(int i = 1;i + len - 1 <= n;i++)
            {
                int j = i + len - 1;
                for(int p = 2;p <= min(len,r);p++)
                {
                    for(int k = i;k < j && p - 1 <= j - k;k++)
                    {
                        dp[i][j][p] = min(dp[i][j][p],dp[i][k][1] + dp[k + 1][j][p - 1]);
                    }
                    if(p >= l)
                    {
                        dp[i][j][1] = min(dp[i][j][1],dp[i][j][p] + sum[j] - sum[i - 1]);
                    }
                }
            }
        }
        if(dp[1][n][1] == INF)printf("0\n");
        else printf("%d\n",dp[1][n][1]);
    }
    return 0;
}

发布了676 篇原创文章 · 获赞 18 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104204399