HihoCoder - 1636 — Pangu and Stones (区间dp)

版权声明:沃斯里德小浩浩啊 https://blog.csdn.net/Healer66/article/details/82555397

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

Input

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

Output

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

Sample Input

3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4

Sample Output

9
6
0

题意:

n个石子堆排成一排,每次可以将连续的最少L堆,最多R堆石子合并在一起,消耗的代价为要合并的石子总数。求合并成1堆的最小代价,如果无法做到输出0。

思路:

区间dp

dp[i][j][k]表示区间[i, j]分成k堆的最小代价,转移有

k=1时:

dp[i][j][1] = min(dp[i][p][x-1]+dp[p+1][j][1]+sum[i][j] )(i<=p<=j-1;L<=x<=R)

k>1时:

dp[i][j][k] = min(dp[i][p][k-1]+dp[p+1][j][1] )( i<=p<=j-1)

参考:https://blog.csdn.net/jaihk662/article/details/78575198

#include <bits/stdc++.h>
#define N 108
using namespace std;
typedef long long ll;
const int inf =1e9+7;
const ll  maxn = 9999999;
int dp[N][N][N],sum[N];
int main()
{
    int n,l,r;
    while(scanf("%d%d%d",&n,&l,&r)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&sum[i]);
            sum[i]+=sum[i-1];//sum[i]表示前i堆的和
        }
        for(int i=0;i<=n;i++)//初始化dp
            for(int j=0;j<=n;j++)
              for(int k=0;k<=n;k++)
                 dp[i][j][k]=inf;
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
             dp[i][j][j-i+1]=0;//把区间i-j全部分开的置成0

         for(int d=1;d<n;d++)//枚举区间长度
         {
             for(int i=1;i+d<=n;i++)//枚举区间起点
             {    //先dp的是合成一份的情况,因为要从小往大推
                 for(int j=i;j<i+d;j++)//枚举区间中点
                    for(int k=l-1;k<r;k++)//枚举左半边堆数
                      dp[i][i+d][1]=min(dp[i][i+d][1],dp[i][j][k]+dp[j+1][i+d][1]+sum[i+d]-sum[i-1]);
                 //再dp合成多份的情况
                 for(int j=2;j<=d;j++)//枚举堆数
                   for(int k=i;k<i+d;k++)//枚举中点
                    dp[i][i+d][j]=min(dp[i][i+d][j],dp[i][k][j-1]+dp[k+1][i+d][1]);
             }
         }
           if(dp[1][n][1]==inf)dp[1][n][1]=0;
        printf("%d\n",dp[1][n][1]);
    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/Healer66/article/details/82555397