[ICPC 北京 2017 J题]HihoCoder 1636 Pangu and Stones

#1636 : Pangu and Stones

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

输入

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

输出

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

扫描二维码关注公众号,回复: 5462560 查看本文章
样例输入
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
样例输出
9
6
0

【题意】

n个石子堆排成一排,每次可以将连续的最少L堆,最多R堆石子合并在一起,消耗的代价为要合并的石子总数。

求合并成1堆的最小代价,如果无法做到输出0

 

【分析】

石子归并系列题目,一般都是区间DP,于是——

dp[i][j][k] ij 分为k堆的最小代价。显然 dp[i][j][ j-i+1]代价为0

然后[i,j] 可以划分

dp[i][j][k]  = min { dp[i][d][k-1] + dp[d+1][j][1] } (k > 1&&d-i+1 >= k-1,这个条件意思就是 区间i,d之间最少要有k-1个石子

最后合并的时候 

dp[i][j][1] = min{ dp[i][d][k-1] + dp[d+1][j][1]  + sum[j] - sum[i-1] }  (l<=k<=r)

 

【代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=105;
int n,L,R,s[N],f[N][N][N];
inline void Init(){
	for(int i=1;i<=n;i++) scanf("%d",s+i),s[i]+=s[i-1];
}
inline void Solve(){
	memset(f,0x3f,sizeof f);
	for(int i=1;i<=n;i++){
		for(int j=i;j<=n;j++){
				f[i][j][j-i+1]=0;
		}
	}  
	for(int i=n-1;i;i--){
		for(int j=i+1;j<=n;j++){
			for(int k=i;k<j;k++){
				for(int t=L;t<=R;t++){
					f[i][j][1]=min(f[i][j][1],f[i][k][t-1]+f[k+1][j][1]+s[j]-s[i-1]);
				}
				for(int t=2;t<j-i+1;t++){
					f[i][j][t]=min(f[i][j][t],f[i][k][t-1]+f[k+1][j][1]);
				}
			}
		}
	}
	ll ans=f[1][n][1];
	printf("%d\n",ans<0x3f3f3f3f?ans:0);
}
int main(){
	while(scanf("%d%d%d",&n,&L,&R)==3){
		Init();
		Solve();
	}
	return 0;
} 

猜你喜欢

转载自www.cnblogs.com/shenben/p/10494993.html