PAT (Basic Level) Practice (中文)1044 火星数字 (20 分)(Java实现)

题目描述:

火星人是以 13 进制计数的:

地球人的 0 被火星人称为 tret。地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

代码示例(Java实现)

import java.util.Scanner;
import java.util.Map;
import java.util.HashMap;

public class Main {

    private static String[] ge = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
    private static String[] shi = {"", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};

    private static Map<String, Integer> map = new HashMap<>();

    static {
        map.put("tret", 0);
        map.put("jan", 1);
        map.put("feb", 2);
        map.put("mar", 3);
        map.put("apr", 4);
        map.put("may", 5);
        map.put("jun", 6);
        map.put("jly", 7);
        map.put("aug", 8);
        map.put("sep", 9);
        map.put("oct", 10);
        map.put("nov", 11);
        map.put("dec", 12);
        map.put("tam", 13);
        map.put("hel", 13 * 2);
        map.put("maa", 13 * 3);
        map.put("huh", 13 * 4);
        map.put("tou", 13 * 5);
        map.put("kes", 13 * 6);
        map.put("hei", 13 * 7);
        map.put("elo", 13 * 8);
        map.put("syy", 13 * 9);
        map.put("lok", 13 * 10);
        map.put("mer", 13 * 11);
        map.put("jou", 13 * 12);
    }

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int count = Integer.parseInt(cin.nextLine());
        for (int i = 0; i < count; i++) {
            String num = cin.nextLine();
            // 如果是地球语
            if (num.charAt(0) >= '0' && num.charAt(0) <= '9') {
                // 将字符串转化为数字
                int number = Integer.parseInt(num);
                // 取出类似于各位
                int n1 = number % 13;
                int n2 = number / 13;
                // 余数等于 0, 除数为 0,
                if (n2 == 0) {
                    System.out.println(ge[n1]);
                } else {
                    // 如果余数为 0
                    if (n1 == 0) {
                        System.out.println(shi[n2]);
                    } else {
                        System.out.println(shi[n2] + " " + ge[n1]);
                    }
                }
            } else {
                int sum = 0;
                String[] nums = num.split(" ");
                for (int j = 0; j < nums.length; j++) {
                    sum += map.get(nums[j]);
                }
                System.out.println(sum);
            }
        }
    }
}
发布了80 篇原创文章 · 获赞 13 · 访问量 9284

猜你喜欢

转载自blog.csdn.net/qq_39424178/article/details/96501538