Ping pong UVA - 1428(树状数组)

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment).
Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If
two players want to compete, they must choose a referee among other ping pong players and hold the
game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is
higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because
they are lazy, they want to make their total walking distance no more than the distance between their
houses. Of course all players live in different houses and the position of their houses are all different. If
the referee or any of the two contestants is different, we call two games different. Now is the problem:
how many different games can be held in this ping pong street?
Input
The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases,
followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N
distinct integers a1, a2 . . . aN follow, indicating the skill rank of each player, in the order of west to east
(1 ≤ ai ≤ 100000, i = 1 . . . N).
Output
For each test case, output a single line contains an integer, the total number of different games.
Sample Input
1
3 1 2 3
Sample Output
1

题意:
两个数中间加一个数,大小在那两个数之间(可以等于),称为一个比赛,问能组成多少比赛。
思路:
记录一个数左边有多少个数小于他——L[i]
右边有多少个数小于他——R[i]。
那么结果就是L[i] * (n - i - R[i]) + R[i] * (i - 1 - L[i])

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>

using namespace std;

const int maxn = 1e5 + 7;
typedef long long ll;
int n;
int c[maxn],a[maxn];
int L[maxn],R[maxn];

void add(int x,int v)
{
    while(x <= maxn - 1)
    {
        c[x] += v;
        x += x & (-x);
    }
}

int query(int x)
{
    int res = 0;
    while(x)
    {
        res += c[x];
        x -= x & (-x);
    }
    return res;
}

int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        memset(c,0,sizeof(c));
        scanf("%d",&n);
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i = 1;i <= n;i++)
        {
            L[i] = query(a[i]);
            add(a[i],1);
        }
        memset(c,0,sizeof(c));
        for(int i = n;i >= 1;i--)
        {
            R[i] = query(a[i]);
            add(a[i],1);
        }
        ll ans = 0;
        for(int i = 1;i <= n;i++)
        {
            ans += 1ll * L[i] * (n - i - R[i]) + 1ll * R[i] * (i - 1 - L[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

发布了635 篇原创文章 · 获赞 17 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104096784