HDU - 2492 Ping pong 【树状数组】

版权声明:本文为博主原创文章,转载请注明出处( • ̀ω•́ )✧ https://blog.csdn.net/wangws_sb/article/details/89503327

题目传送门

题目描述

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). 
Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.
The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1 3 1 2 3

Sample Output

1

解题思路

考虑第 i 个人当裁判的情形。假设a [1] 到a [i-1]中有c [i] 个比a小,那么就有(i-1)- c [i]  比 a [i] 大;同理,假设 a [i+1] 到 a [n] 中有 d [i] 个比 a [i] 小的,那么就有 (n-i)- d[i] 个比 a [i] 大的。根据乘法原理和加法原理,i 当裁判有 c [i] *( (n-i)- d[i] )+((i-1)- c [i] )*d [i] 种比赛。这样问题就转化为求 c[i] 和 d[i]

可以用树状数组求 c[i] 和 d[i] 。

AC代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <set>
using namespace std;
#define io ios::sync_with_stdio(0),cin.tie(0)
#define ms(arr) memset(arr,0,sizeof(arr))
#define mc(a,b) memcpy(a,b,sizeof(b))
#define inf 0x3f3f3f
#define fin freopen("in.txt", "r", stdin)
#define fout freopen("out.txt", "w", stdout)
typedef long long ll;
typedef unsigned long long ULL;
const int mod=1e9+7;
const int N=1e5+7;
int t,n;
ll a[N],c[N],aa[N],bb[N],cc[N],dd[N];
ll lowbit(ll x)
{
    return x&(-x);
}
void add(ll x,ll d){
    while(x<=N){
        c[x]+=d;
        x+=lowbit(x);
    }
}
ll sum(int x)
{
    ll ret=0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}
int main()
{
//    fin;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%lld",&a[i]);
        }
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++){
            add(a[i],1);
            aa[i]=sum(a[i]-1);//左边小于a[i]的数的个数
            bb[i]=i-1-aa[i];//左边大于a[i]的数的个数
        }
        memset(c,0,sizeof(c));
        for(int i=n;i>0;i--)
        {
            add(a[i],1);
            cc[i]=sum(a[i]-1);//右边小于a[i]的数的个数
            dd[i]=n-i-cc[i];//右边大于a[i]的数的个数
        }
        ll ans=0;
        for(int i=1;i<=n;i++){
            ans+=aa[i]*dd[i]+bb[i]*cc[i];
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/89503327