UVALive - 4329 Ping pong()

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment).
Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If
two players want to compete, they must choose a referee among other ping pong players and hold the
game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is
higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because
they are lazy, they want to make their total walking distance no more than the distance between their
houses. Of course all players live in different houses and the position of their houses are all different. If
the referee or any of the two contestants is different, we call two games different. Now is the problem:

how many different games can be held in this ping pong street?

Input
The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases,
followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N
distinct integers a1, a2 . . . aN follow, indicating the skill rank of each player, in the order of west to east

(1 ≤ ai ≤ 100000, i = 1 . . . N).

Output

For each test case, output a single line contains an integer, the total number of different games.


Sample Input
1
3 1 2 3
Sample Output
1

代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int N=2*1e4+5;
const int M=1e5+5;
int L[N],R[N],a[N];
int C[M];//下标为 skil rank 放的是以当前rank为裁判所举行的比赛场数  
int lowbit(int x)//返回二进制的x从右往左数第一个1的位置 
{
	//return x-(x&(x-1));
	return x&-x;
}

void add(int x,int y)//以x为rank的,人数+y 
{
	for(int i=x;i<M;i+=lowbit(i))//M。。。 
	{
		C[i]+=y;
	}
}
int sum(int x)
{
	int all=0;
	for(int i=x;i>0;i-=lowbit(i))
	{
		all+=C[i];
	}
	return all;
}

int main(void)
{
	int t;
	scanf("%d",&t); 
	while(t--)
	{
		int n,i;
		scanf("%d",&n);
		memset(C,0,sizeof(C));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			add(a[i],1);
			L[i]= sum(a[i]-1);//sum(a[i])表示在a[i]左边小于等于a[i]的人数 
		}
		memset(C,0,sizeof(C));
		for(i=n;i>=1;i--)//从右往左每次都实时计算R[i],想一想先大后小和先小后大的区别 
		{
			add(a[i],1);
			R[i]=sum(a[i]-1);//-1
		}
		long long ans=0;
		for(i=1;i<=n;i++)
		{
			ans+=(long long)L[i]*(long long)(n-i-R[i])+(long long)R[i]*(long long)(i-1-L[i]);
		}
		printf("%lld\n",ans);
	}
	return 0;
 } 




猜你喜欢

转载自blog.csdn.net/nucleare/article/details/80956995