【待完善】UVALive-4329:Ping pong

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wingrez/article/details/82975669

UVALive-4329:Ping pong

来源:UVALive

标签:树状数组

参考资料:

相似题目:

题目

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem:
how many different games can be held in this ping pong street?

输入

The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases, followed by T lines each of which describes a test case. Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 . . . aN follow, indicating the skill rank of each player, in the order of west to east (1 ≤ ai ≤ 100000, i = 1 . . . N).

输出

For each test case, output a single line contains an integer, the total number of different games.

输入样例

1
3 1 2 3

输出样例

1

参考代码

#include<stdio.h>
#include<string.h>
#define MAXN 100000
int a[MAXN+5];
int x[MAXN+5];
int c[MAXN+5],d[MAXN+5];
int n;

inline int lowbit(int x){ return x&-x; }

void update(int d){
    while(d<=MAXN){
        x[d]++;
        d+=lowbit(d);
    }
}

int sum(int d){
    int ret=0;
    while(d>0){
        ret+=x[d];
        d-=lowbit(d);
    }
    return ret;
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
      scanf("%d",&n);
      for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
      }
      memset(x,0,sizeof(x));
      for(int i=1;i<=n;i++){
        c[i]=sum(a[i]);
        update(a[i]);
      }
      memset(x,0,sizeof(x));
      for(int i=n;i>=1;i--){
        d[i]=sum(a[i]);
        update(a[i]);
      }
      long long sum=0;
      for(int i=1;i<=n;i++){
        sum+=c[i]*(n-i-d[i])+(i-c[i]-1)*d[i];
      }
      printf("%lld\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/82975669