Ping pong (hdu 2492)

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4870    Accepted Submission(s): 1776

Problem Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). 
Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.
The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1

3 1 2 3

Sample Output

1

题意:当裁判的那个人必须处在这两个比赛者之间,且裁判的能力值不能同时高于或低于这两个人.问一共有多少种比赛组织方式.

假设第i个人为裁判,L[i]表示[1,i-1]小于等于a[i]的人数,R[i]表示[i+1,n]小于等于a[i]的人数。推出公式,以a[i]为裁判的种数即为L[i]*(n-i-R[i])+(i-1-L[i])*R[i]。又是前缀和问题,树状数组走一波。

#include<bits/stdc++.h>
using namespace std;
const int maxn=2e4+5;
int L[maxn],R[maxn],c[(int)1e5+5],a[maxn],maxa;
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int ans=0;
    while(x>0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
void add(int x,int d)
{
    while(x<=maxa)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        maxa=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            maxa=max(maxa,a[i]);
        }
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            L[i]=sum(a[i]);
            printf("L %d\n",L[i]);
            add(a[i],1);
        }
        memset(c,0,sizeof(c));
        for(int i=n;i>=1;i--)
        {
            R[i]=sum(a[i]);
            printf("R %d\n",R[i]);
            add(a[i],1);
        }
        long long ans=0;
        for(int i=1;i<=n;i++)
            ans+=(long long)L[i]*(n-i-R[i])+(long long)(i-1-L[i])*R[i];
        printf("%lld\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81431604