poj3928 Ping pong 树状数组

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case. 
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games. 

Sample Input

1 
3 1 2 3

Sample Output

1


我很笨....没有想到知道了排名为i和左侧比他能力值小的人有l个之后,右侧比他能力值小的人就有i-1-l个.....然而我是很笨的做了两遍.....还懒得离散...


#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define lowbit(i) (-i)&i
const int maxn=100020;
int a[maxn];
int n,c[maxn],x[maxn],y[maxn];
long long sum(int i){
	long long s=0;
	while(i){
		s+=c[i];
		i-=lowbit(i);
	}
	return s;
}
void add(int i){
	while(i<maxn){
		c[i]++;
	    i+=lowbit(i);
	}
}
int main()
{
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(c,0,sizeof(c));
		memset(x,0,sizeof(x));
		memset(y,0,sizeof(y));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			add(a[i]);
			x[i]=sum(a[i]-1);
		}
		memset(c,0,sizeof(c));
		for(i=n;i;i--)
		{
			add(a[i]);
			y[i]=sum(a[i]-1);
		}
		long long ans=0;
		for(i=1;i<=n;i++)ans+=x[i]*(n-i-y[i])+(i-x[i]-1)*y[i];
		printf("%lld\n",ans);
	}
}


猜你喜欢

转载自blog.csdn.net/yslcl12345/article/details/50908508