PTA 团体程序设计天梯赛-练习集 L2-008 最长对称子串 (25分)

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11
思路: 枚举对称串的中心!!!!
    -而一个字符串的中心有2种情况:1种是单个字符(整个字符串的长度是奇数),1个是两个字符(整个字符串的长度是偶数)
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1e6+10;
typedef long long ll;
string s;
int main()
{
	getline(cin,s);
	int len=s.size();
	int max=1,ans=0;
	int x,y;
	for(int i=0;i<len-1;i++)  // 以 i 和 i + 1 为中心
	{
		ans=0;
		x=i;
		y=i+1;
		while(s[x]==s[y]&&x>=0&&y<len)
		{
			x--;
			y++; 
			ans+=2;
		}
		if(ans>max)
		max=ans;
	}
	for(int i=1;i<len-1;i++)  // 以 i为 中心
	{
		ans=1;
		x=i-1;
		y=i+1;
		while(s[x]==s[y]&&x>=0&&y<len)
		{
			x--;
			y++;
			ans+=2;
		}
		if(ans>max)
		max=ans;
	}
	cout<<max<<endl; 
 	return 0;
}
 
发布了349 篇原创文章 · 获赞 32 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_41514525/article/details/104062875