L2-008 最长对称子串 (25 分)

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:
输入在一行中给出长度不超过1000的非空字符串。

输出格式:
在一行中输出最长对称子串的长度。

输入样例:
Is PAT&TAP symmetric?
输出样例:
11

直接俩层暴力循环 不用那种dp 或者求高效求

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s;
    getline(cin,s);
    int maxn=1;
    int len=s.length();
    for(int i=0;i<len;i++){
        string t;
        for(int j=i;j<len;j++){
            t+=s[j];
            string tt=t;
            reverse(tt.begin(),tt.end());
            if(tt==t){
                maxn=max(maxn,(int)t.size());
            }
        }
    }
    cout<<maxn<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/CC_1012/article/details/88058138