POJ2253 - Frogger(预处理 + 最短路)

Frogger   POJ2253

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

sample input

2
0 0
3 4

3
17 4
19 4
18 5

0

sample output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:给你N个石头,从第一个石头跳到第二个石头,每条路径中相距最大的两块石头之间的距离为“青蛙距离”,求所有路径中最小的青蛙距离

思路:需要预处理的最短路径问题,处理过后求路径中最大距离的最小值

#include <iostream>
#include <algorithm>
#include <cmath>
#include <stdio.h>
#define inf 0x3f3f3f3f3f3f
using namespace std;
double a[205][205], x[205], y[205];
int main()
{
    std::ios::sync_with_stdio(0);
    int n, i, j, k, t = 1;
    while(cin >> n)
    {
        if(n == 0)break;
        for(i = 1; i <= n; i++)
        {
            cin >> x[i] >> y[i];
        }
        for(i = 1; i <= n; i++)
        {
            for(j = i; j <= n; j++)
            {
                double w = sqrt((x[i] - x[j]) * (x[i] - x[j]) + (y[i] - y[j]) * (y[i] - y[j]));
                a[i][j] = w;
                a[j][i] = w;
            }
        }
        for(k = 1; k <= n; k++)
        {
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= n; j++)
                {
                    a[i][j] = min(a[i][j], max(a[i][k], a[k][j]));
                }
            }
        }
        printf("Scenario #%d\nFrog Distance = %.3f\n\n", t++, a[1][2]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_16530503/article/details/80461032