Frogger poj2253

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

这题的意思是要求单次跳跃距离最小

魔改一下算法就好了

#include<iostream>
#include<cstring>
#include<cmath>
#define clr(a,b) memset(a,b,sizeof(a));
#define inf 999999
using namespace std;
double map[1005][205],dis[205];
int n,visit[205];
struct node
{
	int x,y;
};
node poi[205];
double dir(node x,node y)
{
	return sqrt((double)((x.x-y.x)*(x.x-y.x)+(x.y-y.y)*(x.y-y.y)));
}

void dilstra()
{
	clr(visit,0)
	for(int i=1;i<=n;i++)
	{
		dis[i]=(i==1)?0:inf;
	} 
	for(int i=1;i<=n;i++)
	{
		int minn=inf,s;
		for(int j=1;j<=n;j++)
		{
			if(dis[j]<=minn&&!visit[j])
			{
				minn=dis[j];
				s=j;
			}
		}
		visit[s]=1;
		for(int j=1;j<=n;j++)
		{
			dis[j]=min(dis[j],max(dis[s],map[s][j]));//这个就是 0->s==dis[s]	s->j==map[s][j]为了到达j,蛙的跳跃能力必须是他们两个最大的
			//也就是要求每条路径点与点的权值的最大值最小  
		}
	}
}

int main()
{
	ios::sync_with_stdio(false);
	int cnt=0;
	while(cin>>n)
	{		
		if(!n) break;
		
		for(int i=1;i<=n;i++)
		{
			cin>>poi[i].x>>poi[i].y;
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{		
				map[j][i]=map[i][j]=dir(poi[i],poi[j]);			
			}
		}
		dilstra();
		//if(cnt)	printf("\n");
		printf("Scenario #%d\n",++cnt);
		printf("Frog Distance = %.3f\n\n",dis[2]);		
	}
	return 0;
}
扫描二维码关注公众号,回复: 3403265 查看本文章

猜你喜欢

转载自blog.csdn.net/weixin_41544329/article/details/82535026
今日推荐