【PAT】A1128 N Queens Puzzle (20point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 300 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1128 N Queens Puzzle (20point(s))

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​ ,Q​2​​ ,⋯,Q​N​​ ), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

8q.jpg 9q.jpg
Figure 1 Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ … Q​N​​ ", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​ ≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

Code

#include <stdio.h>
#include <stdlib.h>
int main(){
    int k,n,flag,isshow[1010];
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&n);
        flag=1;
        for(int j=1;j<=n;j++){
            scanf("%d",&isshow[j]);
            for(int k=1;k<j;k++){
                if(isshow[k]==isshow[j]||abs(isshow[j]-isshow[k])==abs(j-k)){
                    flag=-1;
                    break;
                }
            }
        }
        if(flag==1) printf("YES\n");
        else    printf("NO\n");
    }
    return 0;
}

Analysis

-经典的n皇后问题

-注意判断是否在对角线上,可以用横纵坐标差值是否相等来判断

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103943393