PAT甲级——1128 N Queens Puzzle (20 分)

1128 N Queens Puzzle (水题,数组的应用)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg   9q.jpg
Figure 1   Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ ... Q​N​​", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

题目大意:给出K个测试队列,每个队列有N个数据,第i个数字Qi就表示第i列第Qi行有一个女皇,判断棋盘上的女皇互相有没有威胁;而女皇之间无威胁的情况是女皇当前所在行与列以及斜对角线均没有其他女皇。

思路:每次开辟一个数组用来标记每一行的女皇存在情况,用来判断有没有女皇在同一行;对每两个节点进行判断,行与行之间的差等于列与列之间的差就说明它俩互相有威胁。

#include <iostream>
#include<vector>
#include<cmath>
using namespace std;
struct node {
	int row, col;
};
bool diaCheck(vector<node> &queen);
int main()
{
	int K;
	scanf("%d", &K);
	for (int i = 0; i < K; i++) {
		int N, flag = true;
		scanf("%d", &N);
		vector<bool> rowCheck(N + 1, false);
		vector<node> queen(N+1);
		for (int j = 1; j <= N; j++) {
			scanf("%d", &queen[j].row);
			queen[j].col = j;
			if(!rowCheck[queen[j].row])
				rowCheck[queen[j].row] = true;
			else flag = false;
		}
		if (flag&&diaCheck(queen))
			printf("YES\n");
		else
			printf("NO\n");
	}
}
bool diaCheck(vector<node> &queen)
{
	int rowDiffer, colDiffer;
	int len = queen.size();
	for (int i = 1; i < len-1; i++) {
		for (int j = i + 1; j <= len-1; j++) {
			rowDiffer = abs(queen[i].row - queen[j].row);
			colDiffer = abs(queen[i].col - queen[j].col);
			if (rowDiffer == colDiffer)
				return false;
		}
	}
	return true;
}

猜你喜欢

转载自blog.csdn.net/weixin_44385565/article/details/89074777