pat甲级1128. N Queens Puzzle (20)

原题链接:https://www.patest.cn/contests/pat-a-practise/1128

欢迎访问我的pat甲级题解目录哦https://blog.csdn.net/richenyunqi/article/details/79958195

1128. N Queens Puzzle (20)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1, Q2, ..., QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

 
Figure 1
 
Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1 < K <= 200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4 <= N <= 1000 and it is guaranteed that 1 <= Qi <= N for all i=1, ..., N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print "YES" in a line; or "NO" if not.

Sample Input:
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
Sample Output:
YES
NO
NO
YES

算法设计:

判断是否在同一斜线上的方法是:判断两个点横坐标与横坐标之差是否等于纵坐标与纵坐标之差

c++代码:

#include<bits/stdc++.h>
using namespace std;
int K,N,A[1005];
bool judge(){
    for(int i=1;i<N+1;++i)
        for(int j=i+1;j<N+1;++j)
            if(A[j]==A[i]||abs(j-i)==abs(A[j]-A[i]))
                return false;
    return true;
}
int main(){
    scanf("%d",&K);
    while(K--){
        scanf("%d",&N);
        for(int i=1;i<N+1;++i)
            scanf("%d",&A[i]);
        printf("%s\n",judge()?"YES":"NO");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/richenyunqi/article/details/80172357