PAT 1128 N Queens Puzzle[对角线判断]

1128 N Queens Puzzle(20 分)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1​​,Q2​​,,QN​​), where Qi​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg   9q.jpg
Figure 1   Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K200). Then K lines follow, each gives a configuration in the format "Q1​​ Q2​​ ... QN​​", where 4N1000 and it is guaranteed that 1Qi​​N for all i=1,,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

 题目大意:给出n皇后的一个向量,判断是否是解,输入数据已经保证了所有皇后都不在同一列,n皇后问题中,要求皇后不在同一行同一列,不在对角线上!

//1.首先判断是否在同一行上,即是否有重复数字出现;2.判断是否在对角线上,这怎么判断呢? 只能想出来用邻接矩阵存,,但感觉会内存超限。

代码来自:https://www.liuchuo.net/archives/3796

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int main() {
    int k, n;
    cin >> k;
    for (int i = 0; i < k; i++) {
        cin >> n;
        vector<int> v(n);
        bool result = true;
        for (int j = 0; j < n; j++) {
            cin >> v[j];
            for (int t = 0; t < j; t++) {
                if (v[j] == v[t] || abs(v[j]-v[t]) == abs(j-t)) {
                    //不能在同一行中,
                    //判断是否在同意对角线上可以通过
                    //判断两个行对应相减和两个列对应相减,判断是否在对角线上
                    //如果在对角线上,那么二者相等!
                    result = false;//跟它之前的去判断,
                    break;
                }
            }
        }
        cout << (result == true ? "YES\n" : "NO\n");
    }
    return 0;
}

1.通过两个点的行相减,列相减,如果绝对值相等那么就是在同一对角线上。

猜你喜欢

转载自www.cnblogs.com/BlueBlueSea/p/9553893.html